Reply
 
Thread Tools Display Modes
 
Old 06-09-2014, 10:01 PM   #1
New Member
 
Join Date: Jun 2014
Location: Iowa
Posts: 1
Year: 1992
Coachwork: International
Chassis: Ward
Engine: 466
Rated Cap: 70
466 International Power Loss

I have a 1992 70 pass skoolie with a 466 International and an Allison AT transmission. The motor seems to be cutting out/loosing power on a 15 second cycle at around 2500 rpms or when moving up to speed. She sputters and pushes out gray smoke and leaves an unspent fuel smell in the bus and losses about two to five RPMs or abut 5 MPH. At times she cuts out all together for a second or two and then comes back to life. I converted her about 4 years ago and have made several trips from North Central Iowa to Northern MN with no problems until this started last spring. I nor my diesel mechanic friends can figure out the problem. they are leaning towards a pump rebuild which will cost me 2k - that is what I paid for the bus - Ouch. converting the bus is one ting but I am not a mechanic. Any help would be appreciated. Oh - it is a diesel and it doe snot have the electronics. i have changed the filters several times so I know it is not filters... I checked the fuel line for leaks thinking it may be getting air but found nothing. Wondering if it could be injectors?
bleckrone is offline   Reply With Quote
Old 06-10-2014, 02:07 PM   #2
Site Team
 
crazycal's Avatar
 
Join Date: Feb 2007
Posts: 4,087
Re: 466 International Power Loss

Not a mechanic but I would start checking the simple and cheap stuff first. Fuel filer, shutoff solenoid, broken or shorting wires, battery cables and connections. If your mechanic doesn't know what it is but wants to go straight to the IP before diagnosing the problem would send me to another mechanic. Replacing parts the you don't know are broken is a fast way to go broke.
__________________
I'm hungry!

You Gotta Let Me Fly
crazycal is offline   Reply With Quote
Old 06-10-2014, 03:50 PM   #3
Bus Crazy
 
opus's Avatar
 
Join Date: May 2010
Location: Montana
Posts: 1,615
Year: 1995
Coachwork: Blue Bird
Chassis: All-American R/E
Engine: 8.3 Cummins
Rated Cap: 72
Re: 466 International Power Loss

I didnt think they were governed that high. Anyways, will it do it if you sit in neutral and run it up or is it just under load? Whats the engine temp when you are doing this...normal? You're not running veggie fuel, are you? You could pull the filters and fill them with Power Service and run that through it and see if that helps clean it. Start simple and go from there. Sounds like an injector issue to me.
opus is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Total loss. Motorhome burns as owner explains what happened lornaschinske Everything Else | General Skoolie Discussions 3 04-14-2012 02:03 PM
Heat loss/gain opus Heating, Cooling and Appliances 1 02-14-2012 12:40 PM
power loss how to? adamanderr Conversion General Discussions 7 12-13-2010 01:09 AM
DC or AC power? Locutus Electrical, Charging and Solar 3 07-31-2010 08:44 PM
ATX PC Power Supply to a 12 Volt Power Source vonslatt Everything Else | General Skoolie Discussions 3 02-15-2006 07:57 PM

» Virginia Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.