Reply
 
Thread Tools Display Modes
 
Old 07-30-2018, 03:50 PM   #1
Skoolie
 
Join Date: May 2018
Location: the Missouri Ozarks
Posts: 190
Year: 1997
Coachwork: BlueBird
Chassis: International 3800
Engine: 466e
Rated Cap: its Yuge
Left turn signal not working

I have an international 3600 1997. Somehow in the process of gutting the bus and removing some of the lights for paint, the left turn signal stopped working. The right one still blinks, the left one shows dim and doesn't blink. Anybody have tips on the best way to troubleshoot this?

Thanks,
dave
MambaJack is offline   Reply With Quote
Old 07-31-2018, 09:46 PM   #2
Skoolie
 
Join Date: May 2018
Location: the Missouri Ozarks
Posts: 190
Year: 1997
Coachwork: BlueBird
Chassis: International 3800
Engine: 466e
Rated Cap: its Yuge
So figured this out. I hadnt yet installed one of the blinker lights. When I did, fixed.
MambaJack is offline   Reply With Quote
Old 07-31-2018, 11:10 PM   #3
Bus Crazy
 
Join Date: Feb 2012
Location: Salt Lake City Utah
Posts: 1,541
Year: 2000
Chassis: Blue Bird
Engine: ISC 8.3
That seems a little suspicious: what'll happen when that one lamp burns out? The others stop working too? That's not very good.

Lamps lighting dimly instead of brightly often indicates a bad ground connection. When the ground is poor, the lamp "finds" a ground path through some other lamp. When two lamps end up in series because of a missing ground a person gets dim lights.
family wagon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:25 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.