Reply
 
Thread Tools Display Modes
 
Old 10-21-2013, 10:25 PM   #11
Bus Crazy
 
roach711's Avatar
 
Join Date: May 2010
Location: Farmington Hills, Mi (Detroit area)
Posts: 1,572
Year: 2000
Coachwork: Eldorado Aerotech 24'
Chassis: Ford E-450 Cutaway Bus
Engine: 7.3L Powerstroke
Rated Cap: 19
Re: Our New Bus

So, is your electrical stuff working now? Inquiring minds want to know!

The warm starter sounds like a problem.

Make sure your connections are clean. The connection in your second pic looks like it could use a good going over. I use emery cloth to sand off any corrosion then coat all surfaces with dielectric grease (available at Home Depot/Lowes in the electrical dept). The grease keeps the connection from corroding again.
__________________
The Roach Motel
roach711 is offline   Reply With Quote
Old 10-22-2013, 07:05 AM   #12
Mini-Skoolie
 
Join Date: May 2012
Location: alabama
Posts: 22
Year: 1994
Coachwork: Bluebird
Chassis: TC 2000
Engine: 5.9
Re: Our New Bus

Sorry, I should have explained better but when I said the starter was hot I meant it had power to it. Bus is back cranking and running and everything came back on and is working except the light in the stairwell. Haven't had time to check it out, I hope it's just a blown bulb. It was late, so I haven't tried the jacks yet.. kinda gun shy about it. I plan on going out there and giving it a try today. Thanks for all the info, I'm going to get that grease then and fix that up.
huff0026 is offline   Reply With Quote
Old 10-22-2013, 09:22 PM   #13
Bus Crazy
 
roach711's Avatar
 
Join Date: May 2010
Location: Farmington Hills, Mi (Detroit area)
Posts: 1,572
Year: 2000
Coachwork: Eldorado Aerotech 24'
Chassis: Ford E-450 Cutaway Bus
Engine: 7.3L Powerstroke
Rated Cap: 19
Re: Our New Bus

OMG!!!! A light out in the stairwell?????? Sell it NOW!!

Seriously, I'm glad it was a (relatively) easy fix.

It might be a good idea to put a fuse in the jack circuit before trying it to avoid burning wires again. You're reminding me that I need to add a fuse or two to my battery banks.
__________________
The Roach Motel
roach711 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.