Reply
 
Thread Tools Display Modes
 
Old 09-22-2019, 09:04 PM   #1
Mini-Skoolie
 
Join Date: Aug 2018
Posts: 12
'99 Thomas no crank

My 1999 Thomas Saf-T-Liner will not crank when I turn the key over or push the starter button in the rear. Batteries are charged up, all the dash lights turn on but when I push the start it's just one click from what I believe may be the solenoid. There are no door safety things that prevent starting. It's been a few months since I last drove it and had no problems with it then and I dont believe there as been any changes since.
3126b and Allison transmission.
DJtwreck is offline   Reply With Quote
Old 09-23-2019, 04:09 AM   #2
Bus Crazy
 
Join Date: Sep 2015
Posts: 1,038
Year: 2002
Coachwork: Thomas Built Bus
Chassis: Freightliner FS65
Engine: Caterpillar 3126E Diesel
Rated Cap: 71 Passenger- 30,000 lbs.
Have the batteries been maintained with a good charge? The CAT 3126 engine likes a lot of juice in the batteries.
Native is offline   Reply With Quote
Old 09-23-2019, 09:39 AM   #3
Mini-Skoolie
 
Join Date: Aug 2018
Posts: 12
I believe so. I mean even when it's connected to a battery charger pushing 200A it still doesn't even attempt to crank.
DJtwreck is offline   Reply With Quote
Old 09-23-2019, 10:23 AM   #4
Skoolie
 
Join Date: May 2015
Location: Miami, Fl.
Posts: 150
Year: 1999
Chassis: Amtran / International
Engine: DT466E-Md3060
Quote:
Originally Posted by DJtwreck View Post
I believe so. I mean even when it's connected to a battery charger pushing 200A it still doesn't even attempt to crank.
Do you have an electronic tranny?

The reason I ask is because if your push pad is dark, no lights then bus will not crank.

If not an electronic tranny then I would look at/for a neutral safety circuit that would prevent the bus from cranking.

Oh.... then there's the make sure your ignition switch did not go bad.
ewo1 is offline   Reply With Quote
Old 09-23-2019, 10:49 AM   #5
Mini-Skoolie
 
Join Date: Aug 2018
Posts: 12
Yeah. It has the push buttons on the dash. I can shift them in and out of gear. Only trying to start if it says it's in Neutral. I've tried shifting in and out of neutral a few times to get it started.
DJtwreck is offline   Reply With Quote
Old 09-23-2019, 01:54 PM   #6
Skoolie
 
Join Date: May 2015
Location: Miami, Fl.
Posts: 150
Year: 1999
Chassis: Amtran / International
Engine: DT466E-Md3060
I would check the VIM, not sure about your bus, but there should be 6 relays in the VIM. One of them is for the neutral starter safety. Unplug all 6 relays and reseat them.

Also I would try the #1 old school way for getting a stuck starter to spin, bang on it with a hammer while you hit the ignition switch.

Also don't forget to make sure voltage is reaching the solenoid when you turn the key.
ewo1 is offline   Reply With Quote
Old 09-23-2019, 03:04 PM   #7
Site Team
 
Johnny Mullet's Avatar
 
Join Date: Oct 2017
Location: Ashtabula, Ohio
Posts: 1,207
Year: 1996
Coachwork: Thomas
Chassis: International
Engine: T444E 7.3L
The starter should have a smaller "signal" wire to it and it should light up when the ignition is in the "Start" position or when starter button is pushed. If it lights, there is an issue with the starter motor. Try whacking it with a hammer like suggested only if the signal wire is getting voltage.
Johnny Mullet is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:51 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×