Reply
 
Thread Tools Display Modes
 
Old 09-12-2018, 02:48 PM   #1
New Member
 
Join Date: Sep 2017
Posts: 9
No response to turning the key

I can't get any response from my bus when I turn the key. No lights, no "the emergency exit is open" alarms, no response. According to the dashboard the battery has charge.

I've been really careful about wires...except the stop signs. Obviously the insurance company wanted them off, and I didn't think before cutting those wires. Could that be causing this? Other than that I really haven't touched the wiring, except to disconnect and reconnect the rear lights a couple times.

I called the nearest service station to see if I could pay them to come out, but they want me to tow it to them. That's obviously really expensive so I thought I'd check here first for any obvious solutions....
Kesona Fyren is offline   Reply With Quote
Old 09-12-2018, 02:58 PM   #2
Bus Geek
 
EastCoastCB's Avatar
 
Join Date: Sep 2014
Location: Eustis FLORIDA
Posts: 15,755
Year: 1999
Coachwork: Thomas
Chassis: Freighliner FS65
Engine: Cat 3126
Rated Cap: 15
What year and manufacturer?
__________________
.
Roll Your Own Build Thread
EastCoastCB is offline   Reply With Quote
Old 09-12-2018, 03:36 PM   #3
New Member
 
Join Date: Sep 2017
Posts: 9
Sorry! It's a 2004 International.
Kesona Fyren is offline   Reply With Quote
Old 09-12-2018, 09:10 PM   #4
Bus Nut
 
Johnny Mullet's Avatar
 
Join Date: Oct 2017
Location: Ashtabula, Ohio
Posts: 739
Year: 1996
Coachwork: Thomas
Chassis: International
Engine: T444E 7.3L
Transmission in neutral?
__________________
Mullet's Thunder Bus Build
Johnny Mullet is offline   Reply With Quote
Old 09-17-2018, 01:18 AM   #5
New Member
 
Join Date: Sep 2017
Posts: 9
Yes, I actually cannot move the transmission out of neutral.
Attached Images
File Type: jpg bus 1.jpg (164.8 KB, 6 views)
File Type: jpg bus 2.jpg (145.4 KB, 4 views)
Kesona Fyren is offline   Reply With Quote
Old 09-17-2018, 10:07 AM   #6
Bus Nut
 
johnbloem1974's Avatar
 
Join Date: Jul 2015
Location: Montana/Texas
Posts: 435
Year: 1998
Coachwork: Crown by Carpenter
Chassis: International 3800
Engine: DT 466e/MT 643!
Rated Cap: 16
I would double check the battery at the battery. Dont trust the dash gauges if nothing else is working...

John
johnbloem1974 is offline   Reply With Quote
Reply

Tags
electrical issues, help!, mechanical issues, won't start

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:23 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.