Reply
 
Thread Tools Display Modes
 
Old 04-13-2019, 04:07 PM   #1
Almost There
 
Join Date: Apr 2015
Location: Calgary
Posts: 74
Year: 2000
Coachwork: Bluebird
Chassis: TC2000
Engine: 5.9L Cummins
Radiator blower fan always comes on the first time I pull onto the highway

I dunno if this is normal? I have a 5.9L cummins turbo diesel with an allison at545 transmission.

Regardless of it being hot or cold, every time I first go on the highway, the engine will heat up to over 220 and then the cooling fan will turn on for about 2-3 minutes, bring it back down to 210 and then it will shut off.

Every time.

Is this normal?
-cycosis- is offline   Reply With Quote
Old 04-13-2019, 05:50 PM   #2
Bus Geek
 
o1marc's Avatar
 
Join Date: Dec 2017
Location: Dawsonville, Ga.
Posts: 7,192
Year: 1999
Coachwork: Genesis
Chassis: International
Engine: DT466/3060
Rated Cap: 77
Does it maintain temp after the initial heat up period? if so, sounds like a bad thermostat. 220 is hotter than I like to see during normal use.
o1marc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:41 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.