Reply
 
Thread Tools Display Modes
 
Old 08-25-2017, 05:45 PM   #1
Almost There
 
Join Date: Jun 2017
Posts: 69
Ricon S-Series Wheelchair lift help

The battery on my bus died so I got it replaced and now my wheelchair lift does not work. I flip the switch and the light pulsates red instead of steady red. Any help greatly appreciated as the only thing I am good at when it comes to electrical is releasing the smoke from the wires.
Oldcarnut is offline   Reply With Quote
Old 08-25-2017, 05:56 PM   #2
Bus Crazy
 
Njsurf73's Avatar
 
Join Date: Jan 2017
Location: Massachusetts
Posts: 1,407
Year: 2002
Coachwork: Bluebird
Chassis: Bluebird
Engine: 5.9 Cummins 24v
Rated Cap: 72 pax
Replace with the same size and amp battery? Perhaps it is drawing more current than your battery has available.

Sent from my XT1254 using Tapatalk
Njsurf73 is offline   Reply With Quote
Old 08-25-2017, 06:29 PM   #3
Bus Crazy
 
Join Date: May 2016
Location: Georgia
Posts: 1,050
Year: 2001
Coachwork: Blue Bird
Chassis: IH
Engine: T444E
Rated Cap: 14
If the indicator light is flashing instead of steady, it may 'think' something is wrong. Make sure the emergency doors/windows/hatches are secured, the parking brake is set, transmission in Park/Neutral (and some systems need the engine running to ensure the battery doesn't discharge too much). It may not run without a minimum voltage (not because it can't, but for the same over-discharge prevention reason).
Brad_SwiftFur is offline   Reply With Quote
Old 08-25-2017, 09:35 PM   #4
Almost There
 
Join Date: Jun 2017
Posts: 69
Honestly don't know if battery same, went with a factory spec. Odyssey battery. Don't have the old battery handy but did do the reset button with no luck. I'll be back to the old battery in a week or so and will compare the 2.
Oldcarnut is offline   Reply With Quote
Old 08-25-2017, 10:20 PM   #5
Bus Crazy
 
Join Date: May 2016
Location: Georgia
Posts: 1,050
Year: 2001
Coachwork: Blue Bird
Chassis: IH
Engine: T444E
Rated Cap: 14
If it starts the bus with no difficulty, it's probably not the battery. Might have to drive it a bit to make sure the battery is fully charged.
Brad_SwiftFur is offline   Reply With Quote
Old 08-26-2017, 01:58 AM   #6
Traveling
 
Join Date: Nov 2015
Location: Midwest
Posts: 2,573
Year: 2003
Coachwork: BlueBird
Chassis: TC2000
Engine: 5.9L Cummins
Rated Cap: '00
Quote:
Originally Posted by Brad_SwiftFur View Post
If it starts the bus with no difficulty, it's probably not the battery. Might have to drive it a bit to make sure the battery is fully charged.
did you re-hook up the wheelchair lead when you replaced the battery?

Did you manually try to cycle the wheelchair- may be caught in between a bit.
Rusty is offline   Reply With Quote
Old 08-26-2017, 07:14 AM   #7
Bus Nut
 
Dog Rescuer's Avatar
 
Join Date: Mar 2017
Location: Montana
Posts: 398
Year: 2000
Coachwork: BlueBird
Chassis: International 3800
Engine: 7.3L 210HP Turbo Diesel T444E
Rated Cap: 28 + 3 wheel chairs.
My Lift had a fuse - and a breaker - the "reset" breaker was a small red button.
__________________
- Roger (Dog.Rescuer)
Dog Rescuer is offline   Reply With Quote
Old 08-27-2017, 08:58 AM   #8
Almost There
 
Join Date: Jun 2017
Posts: 69
Battery starts bus no problem, OEM Spec. Oddesey. Have run the bus from WA to CA the last 2 days and still no luck with lift. Reset again and no luck. Will call manufacture Monday as down the street from where I'm staying.
Oldcarnut is offline   Reply With Quote
Old 08-29-2017, 02:40 PM   #9
Almost There
 
Join Date: Jun 2017
Posts: 69
So I reset the relay under the hood, held down the reset button on the lift and was able to get the lift to work. Light on the switch was still flashing but got power to the lift. Cycled lift to make sure all was good to go. Got to destination and no power to lift........ I give up n will pay somebody who has an idea of what they are doing instead of myself shooting blind.
Oldcarnut is offline   Reply With Quote
Old 08-29-2017, 02:47 PM   #10
Bus Nut
 
Join Date: Jun 2013
Location: Picton,Ont, Can.
Posts: 828
Year: 1997
Coachwork: Bluebird
Chassis: GMC
Engine: Cat 3116
Rated Cap: 72
Google the manual for the lift and get an understanding of what is what. Disconnect the battery for 24 hours and then reconnect it. Make sure battery is fully charged at the same time it is disconnected.

John
__________________
Question everything!
BlackJohn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.