Reply
 
Thread Tools Display Modes
 
Old 02-03-2016, 11:30 AM   #1
New Member
 
Join Date: Jan 2016
Posts: 5
Dt466e dies when cruise is turned on

Like the title states, the 466 in our 98 international dies when you turn the cruise control on. The engine will not fire now, but will turn over and all other electrical systems work when the key is in the on position. Anyone ever experienced this and have any pointers to fix it? I am unsure on where to start?
Roachimus is offline   Reply With Quote
Old 02-03-2016, 03:15 PM   #2
Bus Crazy
 
Join Date: Jul 2011
Location: Winlcok, WA
Posts: 1,607
Are you saying the engine dies every time the cruise is turned on or are you saying the engine died when the cruise was turned on and now will not start even though the starter turns?

The model year of your bus suggests you have an electronically controlled engine.

The black box that operates IHC engines is pretty reliable and has few problems. But they do have problems at times.

The only cure is your bus is going to have to be plugged into an IHC engine diagnostic computer.

You can start throwing parts at the problem and eventually find the cure. But spending the $$$ for someone to plug into your bus will probably save you a lot of $$$ in the long run.

If it will start and run except for when the cruise is turned on the problem would be somewhere in the cruise circuit. Even still, unless you access the information in the black box on the bus you can spend a lot of time and $$$ throwing parts at the bus and still never find the problem.
cowlitzcoach is offline   Reply With Quote
Old 02-03-2016, 07:46 PM   #3
New Member
 
Join Date: Jan 2016
Posts: 5
Thank you for the pointers. Took the cruise switch out and unplugged it because I noticed that moisture around the plug trim. Cleaned the switch contacts and walla! Runs great again
Roachimus is offline   Reply With Quote
Old 02-03-2016, 07:53 PM   #4
Bus Nut
 
Join Date: Feb 2015
Location: Cincinnati, Ohio
Posts: 539
Year: 2000
Coachwork: Blue Bird
Chassis: International
Engine: TE 444
Rated Cap: 12
and you need to check if it really has the cruise enabled in the ECU, my 97 has teh cruise switches but it only functions as a fast idle for warm up, cuts out as soon as you put it in gear, the 2000 works as a cruise control
Kubla is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.