Reply
 
Thread Tools Display Modes
 
Old 10-13-2016, 01:43 PM   #1
Mini-Skoolie
 
Join Date: Oct 2015
Posts: 59
Help with check engine light

So I have a 5.9 cummins 12 valve mechanical motor in a 97 bluebird. Had a cracked head replaced it. No water leaks no oil in the coolant . When we fired her up today she had trouble at first then she smoothed out but the check engine light was on and it was beeping. Any thoughts?
Sunbear is offline   Reply With Quote
Old 10-13-2016, 02:13 PM   #2
Bus Geek
 
Join Date: May 2009
Location: Columbus Ohio
Posts: 3,079
Year: 1991
Coachwork: Carpenter
Chassis: International S3800
Engine: DT360
Rated Cap: 7 Row Handicap
sometimes under the dash where the diagnostic connector is, theres a "diagnostic button"..

turn on the key but without the engine running, and press that button.. the check engine light will flash out sequences which are the error codes.. might be able to match the codes up to a sensor..

my guess is likely just a wire or something didnt get plugged back in tight.. make sure the engine ground is good.. should be a large strap screwed into the block and maybe the head, which goes to the frame.. if that isnt making good contact, sensors can wig out..
-Christopher
cadillackid is offline   Reply With Quote
Old 10-13-2016, 05:27 PM   #3
Mini-Skoolie
 
Join Date: Oct 2015
Posts: 59
Cadillac kid heres an update. I just moved her out of the field because of the pouring rain and she started right up and sounded good until ipushed the gas pedal then she bogged a little and had no power ,almost felt like all 6 tires were flat
Sunbear is offline   Reply With Quote
Old 10-13-2016, 05:49 PM   #4
Bus Geek
 
Join Date: May 2009
Location: Columbus Ohio
Posts: 3,079
Year: 1991
Coachwork: Carpenter
Chassis: International S3800
Engine: DT360
Rated Cap: 7 Row Handicap
almost makes me wonder if the HPOP pressure is low causing the injectors to not be able to fire... or is it air brakes and you tried to move it befpre the brake pressure came up?

or was it just bogging because its a heavy vehicle in a wet field trying to get onto the pavement with an auto trans?

-Christopher
cadillackid is offline   Reply With Quote
Old 10-13-2016, 06:09 PM   #5
Mini-Skoolie
 
Join Date: Oct 2015
Posts: 59
It was weird because the thing wanted to fly in reverse but as soon as I put her in drive it just had no power.
Sunbear is offline   Reply With Quote
Old 10-13-2016, 06:30 PM   #6
Mini-Skoolie
 
Join Date: Oct 2015
Posts: 59
Could a vacuum leak cause the sympton of having no power in drive? Could the new 800 head be faulty?
Sunbear is offline   Reply With Quote
Old 10-13-2016, 07:03 PM   #7
Bus Geek
 
Join Date: May 2009
Location: Columbus Ohio
Posts: 3,079
Year: 1991
Coachwork: Carpenter
Chassis: International S3800
Engine: DT360
Rated Cap: 7 Row Handicap
have you checked to make sure all 6 cylinders are firing? the HEUI rail getting air in it is a known issue of causing injectors not to inject fuel...

when you say bogs down.. are your RPMS low even when you are floored? or do the rpms go up and the bus just doesn want to move?

-Christopher
cadillackid is offline   Reply With Quote
Old 10-13-2016, 07:28 PM   #8
Bus Nut
 
Carytowncat's Avatar
 
Join Date: May 2016
Location: Richmond Virginia
Posts: 668
Year: 1984
Engine: 366 Big block Chevy! :) w/ Stick shift
Yeah power in reverse but not forward points towards the transmission...or brakes. My GMC will back up normal but barely move if i forget the emergency brake.

Good luck!
Carytowncat is offline   Reply With Quote
Old 10-13-2016, 10:29 PM   #9
Mini-Skoolie
 
Join Date: Oct 2015
Posts: 59
We figured out the "power" in reverse "no power" forward was that we were rolling back down a hill, but going up hill forward. Not a huge incline, but enough to make the difference.
Sunbear is offline   Reply With Quote
Old 10-13-2016, 10:56 PM   #10
Mini-Skoolie
 
Join Date: Oct 2015
Posts: 59
So my bro who is doing the work thinks it may be when he replaced the tappet cover gasket and put the injection pump on something with the timing he is going to look into it tomorrow. Any new thoughts
Sunbear is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.