Reply
 
Thread Tools Display Modes
 
Old 09-13-2016, 07:46 PM   #1
New Member
 
Join Date: Sep 2016
Location: Tulsa
Posts: 6
Year: 95
Coachwork: Blue bird
Chassis: I think it's a chevy
Engine: I think it's a 6.6 L cat
Rated Cap: 64
Just picked up my bus, now to figure put how to fix these things

Hey there, my partner and I just took the leap and bought a bus . We've helped a bit with other people's conversions, and we are pumped to get to start one of our own. After lots of searching for the best bus that we could, we ended up getting a full sized 95 bluebird. We got it from a local school that retired it with a bunch of others because of age and it's been well maintained up until about a year ago, and it pretty much just sat for that year being moved a few times. It did great on the test drive, there wasn't anywhere that I could really open her up, but she got up to 50 mph easily and cruised there with no problems. After I bought it, I had about a 200 mile drive home. Upon getting on the freeway, I realized that I couldn't get her to go above 50 mph. I figured that the governor must be set there and it chugged along just fine for about 180 miles. That's about the time that I took my foot off of the gas to adjust while going up a hill. After that, it felt like something wasn't catching. I couldn't get her above 30 for the rest of the ride home. I got a diesel knowing that they last forever, but also that I'm completely unaware of how to troubleshoot and work on them. I look forward to learning all about them and how to get this girl running to her full potential. Any advice on where to find a service manual, mechanical and troubleshooting tips, or a good, cheap mechanic that could show me the ropes around the Tulsa area would be greatly appreciated. I'm super excited to be part of the skoolie family!
foresterjon05@gmail. is offline   Reply With Quote
Old 09-13-2016, 08:30 PM   #2
Bus Nut
 
Join Date: Dec 2015
Location: Utah
Posts: 266
Year: 1990
Coachwork: BB
Chassis: TC2000
Engine: Cummins
Rated Cap: 25.999K
Clean it up.

Hi. Congrats on the new purchase. You have left out tons of details about your rig, but based on it being diesel, and it being a 1995, then odds have it that it is a mechanically injected engine. If it has been sitting for a year, it could be as simple as dirty fuel. It doesn't take much to get the pump and injectors not working right. I had some similar problems in my 5.9 12v cummins, I threw some Standyne Injector cleaner in the tank. After about 100 miles of driving, it was back to normal. If you post more info, you'll likely receive better/more info.... goodluck.
SDR76 is offline   Reply With Quote
Old 09-13-2016, 10:04 PM   #3
Bus Nut
 
Carytowncat's Avatar
 
Join Date: May 2016
Location: Richmond Virginia
Posts: 902
Year: 1984
Engine: 366 Big block Chevy! :) w/ Stick shift
Hi,

I wonder if that has fly by wire throttle, like did something get askew when you adjusted your foot? ie linkage, sensor, etc.

I do not know anything sbout your bus though, just a guess

Good luck!
Carytowncat is offline   Reply With Quote
Old 09-14-2016, 12:03 AM   #4
New Member
 
Join Date: Sep 2016
Location: Tulsa
Posts: 6
Year: 95
Coachwork: Blue bird
Chassis: I think it's a chevy
Engine: I think it's a 6.6 L cat
Rated Cap: 64
First of all, thanks for replying. Thank you for the fuel tips as well. It had about half of a tank when I got it and filled it the rest of the way at Walmart. Ate there places that I'm should go to specifically or avoid for fuelunch? I'm new to the diesel and bus world, so I'm not positive how to tell all of the details nor do I know what all info that you would want, but what Google told me when I typed in the Vin was this:
It's a 95 blue bird
6.6 L L6
It says it's a B7T042 Chevy, I'm assuming that's the chassis, but I'm not sure.
It has almost 180k miles on it.
The title says it's a CV20, though a Google search didn't turn up any results for that model.
The guy who sold it to me said that the engine is a cat, I belive he said a cat 5, but he was hard to understand.

As far as the issue goes, I forgot to mention that after the problem started and i pulled off of the highway, the bus made a terrible whining sound that was like metal rubbing against metal. I pulled over and checked the fluids, and they were all fine. I took the backroads home from there and it made the sound one more time. The engine would Rev, but often times it seemed like a gear wouldn't catch or something, so it was pretty slow going.
foresterjon05@gmail. is offline   Reply With Quote
Old 09-14-2016, 05:02 AM   #5
Bus Nut
 
Carytowncat's Avatar
 
Join Date: May 2016
Location: Richmond Virginia
Posts: 902
Year: 1984
Engine: 366 Big block Chevy! :) w/ Stick shift
That sounds like transmission issues.
Carytowncat is offline   Reply With Quote
Old 09-14-2016, 06:57 AM   #6
Bus Geek
 
Join Date: May 2009
Location: Columbus Ohio
Posts: 6,083
Year: 1991
Coachwork: Carpenter
Chassis: International S3800
Engine: DT360
Rated Cap: 7 Row Handicap
a CV20 is a standard conventional chevy chassis I believe you got a shortie Bluebird that has a hood and not a flat nose?

a whine and the metal on metal sound is often a front pump in the transmission fluid starved.. when you checked the transmission fluid was your engine running or did you do it wit hthe engine shut off?

trans fluid should be checked wit hthe engine running and warmed up... and it should be a nice clear red color..

a 1995 likely is an AT545 transmission though it could have the MT643.. the AT545 when operating normally makes some whiney sounds at low speeds.

-Christopher
cadillackid is offline   Reply With Quote
Old 09-14-2016, 07:12 AM   #7
New Member
 
Join Date: Sep 2016
Location: Tulsa
Posts: 6
Year: 95
Coachwork: Blue bird
Chassis: I think it's a chevy
Engine: I think it's a 6.6 L cat
Rated Cap: 64
I checked it with the engine running, is was a pretty clean pinkish red. I had to shuffle my vehicles around today and noticed that the intake heater light came on for a bit.
foresterjon05@gmail. is offline   Reply With Quote
Old 09-20-2016, 10:34 PM   #8
New Member
 
Join Date: Sep 2016
Location: Tulsa
Posts: 6
Year: 95
Coachwork: Blue bird
Chassis: I think it's a chevy
Engine: I think it's a 6.6 L cat
Rated Cap: 64
I looked it over the best that I could after I read up on it and deduced that it is the tranny after all. A mechanic confirmed today. Now I just need to figure out if I should have someone rebuild it, or buy a used one. One guy told me it would be about 900 to rebuild it and I know I can find a used one for around 500 on ebay, so I guess I'll just weigh my options for a bit. Either way, I gotta figure out how to get the old one off. Any advice on where to find tutorials? It is an at545 for sure
foresterjon05@gmail. is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:42 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.