Reply
 
Thread Tools Display Modes
 
Old 04-17-2007, 04:08 PM   #1
Mini-Skoolie
 
Join Date: Mar 2007
Posts: 16
I'm having a brake light problem...

Any help is much appreciated.

It seems as though every other light is in full working order except the brake lights. This is on an '88 IH S1700 Thomas body. Would this be a fuse, or a bad connection? Or maybe something came unplugged?? Not sure...
DGC3 is offline   Reply With Quote
Old 04-17-2007, 04:12 PM   #2
Bus Crazy
 
Steve's Avatar
 
Join Date: Jul 2002
Location: Central Iowa
Posts: 1,838
Send a message via AIM to Steve
I would go a take the lights out and sand all of the connections, many of my lights were irratic until I cleaned up their connection to ground.
__________________
View my 1972 Ward: Topic from the Build : The Picture Gallery
View my 1986 Blue Bird: Topic from the Build : The Picture Gallery
View my 1960 GMC: Topic from the Build : The Picture Gallery
Steve is offline   Reply With Quote
Old 04-17-2007, 11:36 PM   #3
Bus Geek
 
the_experience03's Avatar
 
Join Date: Feb 2006
Location: Saint James, MN
Posts: 2,669
Send a message via MSN to the_experience03 Send a message via Yahoo to the_experience03
If you have air brakes there is a pressure sensing switch as well as the regular fuse, wiring, etc. Like Steve said...start with the easy stuff like getting rid of corrosion and bad bulbs.
__________________
http://farm4.static.flickr.com/3024/...09f20d39_m.jpg
Skooling it...one state at a time...
the_experience03 is offline   Reply With Quote
Old 04-18-2007, 08:37 AM   #4
Bus Geek
 
lapeer20m's Avatar
 
Join Date: Nov 2003
Location: near flint michigan
Posts: 2,653
the brake light switch on my skoolie went bad. I have hydraulic brakes. if you lay on your back and look under the dash at the brake pedal, you'll find the switch....if you have hydraulic brakes. You might even find 2 of them. One for the brakes, and a separate one for the electric/hydraulic backup brake booster.
__________________
Quis custodiet ipsos custodes (who will watch the watchmen?)
lapeer20m is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird tail light problem. REDBEAR HELP! roach711 Conversion General Discussions 8 05-05-2014 03:04 PM
need help walking thru light problem bansil Mechanical and Drivetrains 3 09-01-2012 07:48 PM
head light problem joshritchie Conversion General Discussions 2 12-07-2008 12:25 AM
Air brake problem frank-id Everything Else | General Skoolie Discussions 5 02-14-2008 08:27 PM
Air Brake Problem dlor1 Everything Else | General Skoolie Discussions 7 10-26-2007 08:07 PM

» Virginia Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:13 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.