School Bus Conversion Resources

School Bus Conversion Resources (http://www.skoolie.net/forums/)
-   Conversion General Discussions (http://www.skoolie.net/forums/f13/)
-   -   Fuel guage not working right (http://www.skoolie.net/forums/f13/fuel-guage-not-working-right-3730.html)

newbusser 04-16-2009 01:56 PM

Fuel guage not working right
 
Can anyone tell me how to test a fuel sending unit?

I pulled them out and one looks new and other is very old. when they were in, neither was working right, or at least the gauge wasn't reading correctly. I drained both tanks, and when I selected the drivers side tank it said it was empty, select passenger side it says it's full. I then put ten gallons in each side and tried again....no change. Any suggestions?

paul iossi 04-16-2009 04:15 PM

Re: Fuel guage not working right
 
remove the guages, are the floats empty or full of fuel? if they float hook them up to a ohm meter and slowly move the float assembly thru the range, they should read close to each other in the empty and full positions, if they both test good, adjust the length of the float arms so that the float swings from the bottom of the tank to the top of the tank.

elkoskoolie 04-16-2009 04:44 PM

Re: Fuel guage not working right
 
And make sure that there are no baffles or other obstructions restricting their movement, both now and when (if) you put them back in.

the_experience03 04-16-2009 09:27 PM

Re: Fuel guage not working right
 
Disconnect the wiring from the sender. The gauge should read either full or empty. Then ground the connector with a jumper wire. The gauge should move to the opposite end of the spectrum. If it doesn't you have wiring or gauge issues, not sender issues.

paul iossi 04-16-2009 10:52 PM

Re: Fuel guage not working right
 
also chech the tank switch it should measure no resistance, just continuity from guage terminal to one sener terminal or the other.

newbusser 04-17-2009 01:41 AM

Re: Fuel guage not working right
 
checked each sending unit on bench.( your suggestion was great Vanguy, I just didn't see it till I had them out:)
One showed change in ohmmeter, other didn't so I took them both to the truck parts house and ordered another one just like the one that works. They were two totally different styles, now will be the same. I am going to clean the connecting wires completely before I install them and see what happens.

lapeer20m 04-18-2009 10:35 PM

Re: Fuel guage not working right
 
and make sure the resistance of the sending units is matched to the guage.

newbusser 04-18-2009 10:42 PM

Re: Fuel guage not working right
 
Still fighting it. I am leaning toward bad grounds, but now when I put new sending unit in, both tanks read full, I put switch to center spot and guage says empty. Am going to clean all connections and try some of the troubleshooting techs tomorrow when I have my son available to tell me what the gauge is doing.

Also, I know the tanks are not full because I ran it dry...... there are a number of four letter words I want to use, but decorum forbids it. Got it running again, but took most of the day.

lapeer20m 04-19-2009 11:55 AM

Re: Fuel guage not working right
 
you might want to try getting a new guage if the grounds check out. A sending unit and a guage usually come as a matched set. a guage is designed for a certain amount of resistance, and the sending unit is also designed to provide the proper amount of resistance for that particular guage. Having a guage that does not match a sending unit would make things not work properly.


All times are GMT -5. The time now is 07:16 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.