Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
 
Old 07-22-2021, 09:22 PM   #1
New Member
 
Join Date: May 2021
Posts: 5
Bluebird TC 2000 VDO speedo/tach

I've got a 2003 Bluebird TC 2000 with VDO speedometer and tach. Both sweep arms for speed and RPM's work well, but the number display on the digital LCD odometer on the speedo and the hour meter of the tach do not. Has anyone any ideas on repair, or do I need to replace. Thanks in advance...

Milesollie is offline   Reply With Quote
Old 07-22-2021, 11:10 PM   #2
Bus Crazy
 
Join Date: May 2018
Location: topeka kansas
Posts: 1,009
Year: 1954
Coachwork: wayne
Chassis: old f500- new 2005 f-450
Engine: cummins 12 valve
Rated Cap: 20? five rows of 4?
Vdo

I would

1) find a technical sheet for the gages published by VDO

2) test the wires going to the gages to see if all the inputs are checking to be good

3) if inputs check good, then gages are bad

4) if inputs to not check good . repair inputs

william
magnakansas is offline   Reply With Quote
Old 07-23-2021, 08:57 AM   #3
New Member
 
Join Date: May 2021
Posts: 5
Thanks for your advice magnakansas. Hopefully get to it this weekend.
Milesollie is offline   Reply With Quote
Old 07-23-2021, 11:48 AM   #4
Bus Crazy
 
Join Date: May 2018
Location: topeka kansas
Posts: 1,009
Year: 1954
Coachwork: wayne
Chassis: old f500- new 2005 f-450
Engine: cummins 12 valve
Rated Cap: 20? five rows of 4?
That is a start

More information from doing the wire tests will give an idea of the next step. A way to jump all that, but costs money- buy a known good gage and substitute. Problem with that approach is you might have purchased a gage for no reason.

William
magnakansas is offline   Reply With Quote
Old 07-24-2021, 05:37 PM   #5
New Member
 
Join Date: May 2021
Posts: 5
Vdo

Hey William,
I thought I'd up date you on the speedo troubleshooting. I pulled the dash panel and tried to unscrew the speedo. In the middle of this, my Dad who is in the hospital called and need me to go to Drs. appt with him so I abandoned the project to go with him. Today I started the bus to run a few minutes and charge the batteries, and the odometer faintly showed the numbers. I beleive I must have flexed or 'tweaked' the wires as I tried to unscrew it, possibly making a reconnection. Do you think maybe pulling the connections from the inputs and spraying contact cleaner may make the readout more bold? I didn't mess with the tach yet, just the speedometer.
Thanks for encouraging me to check the gauge out first, hopefully saving us needless replacement expense.
Mike
Milesollie is offline   Reply With Quote
Old 07-24-2021, 07:45 PM   #6
Bus Crazy
 
Join Date: May 2018
Location: topeka kansas
Posts: 1,009
Year: 1954
Coachwork: wayne
Chassis: old f500- new 2005 f-450
Engine: cummins 12 valve
Rated Cap: 20? five rows of 4?
Yup I agree

Yea contact cleaner....if you have ever taken something like a gage apart.... gently gently gently.... you can check internal connections. This is something to do as a last ditch effort. If you have a truck or motor home salvage near you. The rv salvage colaws has bins full of gages.
magnakansas is offline   Reply With Quote
Old 07-25-2021, 05:25 PM   #7
New Member
 
Join Date: May 2021
Posts: 5
Vdo

Thanks again William for your follow up replies; I really appreciate you taking time to help.
Mike
Milesollie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:29 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.