Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
 
Old 08-28-2021, 07:47 PM   #1
New Member
 
Join Date: Aug 2021
Posts: 8
No start 97 international

Hi everyone I have a 97 international 4700 with t444e ran good till stalled out For no reason was able to get it running. Got it home and shut it off. Will not re start. Just cranks. I replaced Icp, ipr cam sensor. And injection pump. Still no start. I bypass my fuel tank thinking that would be the problem and still nothing. New battery's. I do not have a code reader not sure witch one to buy. My injections on the driver side look okay. I do have that cover off. I am pulling the passenger side. What else should I check. Before buying more parts. Thanks.

Tommyboy8072002 is offline   Reply With Quote
Old 08-29-2021, 08:25 AM   #2
Commercial Member
 
Power Hungry's Avatar
 
Join Date: Jul 2020
Posts: 82
Quote:
Originally Posted by Tommyboy8072002 View Post
Hi everyone I have a 97 international 4700 with t444e ran good till stalled out For no reason was able to get it running. Got it home and shut it off. Will not re start. Just cranks. I replaced Icp, ipr cam sensor. And injection pump. Still no start. I bypass my fuel tank thinking that would be the problem and still nothing. New battery's. I do not have a code reader not sure witch one to buy. My injections on the driver side look okay. I do have that cover off. I am pulling the passenger side. What else should I check. Before buying more parts. Thanks.
First question... checked oil level?
Power Hungry is offline   Reply With Quote
Old 08-29-2021, 08:43 PM   #3
New Member
 
Join Date: Aug 2021
Posts: 8
Unhappy

Quote:
Originally Posted by Power Hungry View Post
First question... checked oil level?
Oil level is full. New fuel filter. Antifreeze is also full. I'm going to check the oil pressure. And see what I get for psi. I also ordered a code reader. Won't be here for a week or 2. What about a pump driver module. Is there a way to tell when that goes bad. Thank you for your help.
Tommyboy8072002 is offline   Reply With Quote
Old 08-29-2021, 11:05 PM   #4
New Member
 
Join Date: Aug 2021
Posts: 8
I'm getting rpm reading. On the tack. If I unplug icp It still doesn't fire. Does anyone know if these engines have a cam and a crank sensor. Just thinking maybe i replaced the wrong sensor.
Tommyboy8072002 is offline   Reply With Quote
Old 09-04-2021, 02:13 PM   #5
New Member
 
Join Date: Aug 2021
Posts: 8
Hi everyone can someone please explain to me what would cause the glow plugs to be covered in engine oil.
Tommyboy8072002 is offline   Reply With Quote
Old 09-04-2021, 04:45 PM   #6
Bus Crazy
 
Join Date: Nov 2011
Location: Sault Ste. Marie, Ontario
Posts: 1,779
Year: 1997
Coachwork: Thomas
Chassis: B3800 Short bus
Engine: T444E
Rated Cap: 36
Quote:
Originally Posted by Tommyboy8072002 View Post
Hi everyone can someone please explain to me what would cause the glow plugs to be covered in engine oil.

Are the in-chamber tips coated in engine oil? That means there's an eff ton of oil inside your combustion chamber which is certainly a concern.
The tops of the glow plugs will be coated in oil, being under the valve cover and all.
__________________
My build page: Armageddon - The Smell of Airborne Rust
jazty is offline   Reply With Quote
Old 09-05-2021, 09:58 AM   #7
New Member
 
Join Date: Aug 2021
Posts: 8
Quote:
Originally Posted by Power Hungry View Post
First question... checked oil level?
Engine oil is full.
Tommyboy8072002 is offline   Reply With Quote
Old 09-05-2021, 10:01 AM   #8
New Member
 
Join Date: Aug 2021
Posts: 8
From the threads down to the end of the glow plugs. Is covered in engine oil. Would the injectors cause that. I have never had this happen before.
Tommyboy8072002 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.