Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
 
Old 11-18-2016, 12:48 PM   #1
Skoolie
 
jester's Avatar
 
Join Date: Dec 2015
Location: onboard the R1!
Posts: 226
Year: 2004
Coachwork: International
Chassis: RE200
Engine: 7.3L Navistar T444E
Rated Cap: 72
04 international re200. T444E Fan clutch???

So been having warn engine light come on a bit for high temp coolant. Warm and At idle on cold mornings 40 deg,. The fan clutch will make a chirping sound, while it's chirping it seems like it's trying to turn the fan on but not fully engaging. Belts are tight, didn't overheat at idle, only going to long hills basically normal but can't help wondering if the fan clutch is going or maybe fan clutch selinoid?? Just want to catch it now before next road trip.

jester is offline   Reply With Quote
Old 11-19-2016, 12:18 AM   #2
Bus Crazy
 
Join Date: Nov 2011
Location: Sault Ste. Marie, Ontario
Posts: 1,782
Year: 1997
Coachwork: Thomas
Chassis: B3800 Short bus
Engine: T444E
Rated Cap: 36
90% chance it's the fan clutch. Everyone with a T444e has a bad fan clutch, including me. I haven't fixed mine, I just dump the heat through my interior heaters when it gets too high. Not ideal, but it works. A clutch is on the to-buy-to-do list.

Cadillackid has a good write up about his fan clutch replacements.
__________________
My build page: Armageddon - The Smell of Airborne Rust
jazty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:33 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2023, vBulletin Solutions, Inc.