Reply
 
Thread Tools Display Modes
 
Old 09-13-2020, 05:06 PM   #1
Mini-Skoolie
 
Join Date: Jun 2018
Location: NW Florida
Posts: 68
Year: 2001
Coachwork: International
Engine: DT-466
Allison 545 Transmission Fluid Leak

Hey guys,

Background info: I have a 2001 International 3000 with a DT-466 engine. I was told it had an Allison 2500 transmission when I purchased it (part of why I bought it), but today while climbing underneath, I noticed a big ol' "AT 545" on the transmission.

Anyway...

I just discovered a massive leak when I took my bus for a short drive. I thought it was oil at first, but upon closer inspection, it is reddish, which I think means it's trans fluid (if I'm not mistaken). It only leaks when the bus is on, but it is a huge leak. I have a few videos below I recorded of the leak, and where it's coming from. It looks like the transmission line.

Questions:
1. How difficult would this be to repair myself? (little to no experience - I changed my oil on my pickup once. But, I can learn how to do things if I have a good video walkthrough) If I tried to fix it myself, where do I get the parts/tools necessary?

2. If I take it to a mechanic, how do I get it there without destroying the transmission? It seems like a pretty fast leak, and the nearest mechanic who might work on it is 15 minutes away.

3. I'm in Santa Fe, NM. Is there anyone on here nearby or know of anyone nearby who is able to help fix something like this? There is only one mechanic I know of in the area who might be able to fix it, and I'm not sure if they can or not - but they don't open until tomorrow, so I will have to wait to find out. I'm also on a really really tight budget because of the times we live in. My wife and I are only needing to go about 100 miles to park it permanently on some land we purchased. We were headed out to go there today when this happened. I'm worried the repair cost is going to cost us everything we have... but right now we're stranded until we can get it fixed.

Video 1: https://youtu.be/qK6p1lAXVmw
Video 2: https://youtu.be/6toYQWBYQZM
Video 3: https://youtu.be/RRtVz0wxnqc
Beeb is online now   Reply With Quote
Old 09-13-2020, 05:22 PM   #2
Bus Crazy
 
Join Date: May 2016
Location: Georgia
Posts: 2,069
Year: 2001
Coachwork: Blue Bird
Chassis: IH
Engine: T444E
Rated Cap: 14
Yep, looks like that hose is toast. Where's the other end of it go? Looks like a DIY repair, just remove the old one and get a new one the same length, a custom hose hydraulic shop should be able to make one for a reasonable price.
Brad_SwiftFur is offline   Reply With Quote
Old 09-13-2020, 05:25 PM   #3
Skoolie
 
Join Date: Oct 2018
Location: Central Alabama
Posts: 125
Year: 1998
Coachwork: Blue Bird
Chassis: TC/2000
Engine: 5.9 Cummins 12-valve
Rated Cap: 1
Should go to the radiator. An adjustable wrench to remove the line and a pan to catch the transmission fluid. I just picked up a 99 international with the same Weller reman.
BamaBus is online now   Reply With Quote
Old 09-13-2020, 05:26 PM   #4
Bus Geek
 
Join Date: May 2009
Location: Columbus Ohio
Posts: 13,480
Year: 1991
Coachwork: Carpenter
Chassis: International 3800
Engine: DTA360 / MT643
Rated Cap: 7 Row Handicap
many NAPA stores have hydraulic hose facilities.. the NAPA near a lot of trucking yards is often one wit ha machine shop and they can usually make hydraulic hoses. and they are reasonable.. I recently had a powered steering hose made for one of my busses there.. much less expensive than the parker store and works great.


if you call a local NAPA store and ask if they can make the hose.. chances are if they cant they can point you to the Napa in town that can.
-Christopher
cadillackid is offline   Reply With Quote
Old 09-13-2020, 05:29 PM   #5
Bus Geek
 
o1marc's Avatar
 
Join Date: Dec 2017
Location: Dawsonville, Ga.
Posts: 9,333
Year: 1999
Coachwork: Genesis
Chassis: International
Engine: DT466/3060
Rated Cap: 77
O'Reilly Auto Parts makes custom hydraulic hoses also.
__________________
I Thank God That He Gifted Me with Common Sense
o1marc is offline   Reply With Quote
Old 09-13-2020, 06:00 PM   #6
Mini-Skoolie
 
Join Date: Jun 2018
Location: NW Florida
Posts: 68
Year: 2001
Coachwork: International
Engine: DT-466
This is why I love this place.

You guys are great. I'll look into it and let you know if I run into any issues or any more questions.
Beeb is online now   Reply With Quote
Old 09-13-2020, 06:58 PM   #7
Bus Nut
 
Join Date: Feb 2019
Location: New Hampshire
Posts: 705
Year: 1990
Coachwork: Thomas 4 window w/lift
Chassis: G30
Engine: 350 Chevy
Rated Cap: 10K
As the guys above suggest, Napa or almost any hydraulic shop can make you a replacement.

Try to remove it without damaging it, and simply bring it in "whole" to the shop so they'll have an exact model that is the right length, and so that they'll know the correct sized fittings to use on you new line.

If you can't do it yourself and you don't know anyone that could help you remove it, look on craigslist or facebook for a local mechanic/handyperson who could come to you to do the removal and eventual reassembly once you locate a new line.

I wouldn't advise driving it if it's leaking badly, as you'll smoke the transmission in short order without fluid in it.

Good luck.
peteg59 is offline   Reply With Quote
Old 09-16-2020, 04:49 PM   #8
Mini-Skoolie
 
Join Date: Jun 2018
Location: NW Florida
Posts: 68
Year: 2001
Coachwork: International
Engine: DT-466
Update...

I got two new hoses made (I damaged the good one while trying to remove the bad one, so I had to replace the other one too). I got three of the four connections connected. But the last connection (where the leak originally was) is just spinning and spinning without catching and screwing on. I've tried everything I can, but I can't get it to take hold. I think the threads might be stripped on the transmission-side (not the hose - the hose looks fine). I'm not sure how to move forward...

Video showing details:
Beeb is online now   Reply With Quote
Old 09-16-2020, 05:35 PM   #9
Bus Crazy
 
Jolly Roger bus 223's Avatar
 
Join Date: Sep 2017
Location: Swansboro,NC
Posts: 1,268
Year: 86
Coachwork: Thomas
Chassis: Ford B700
Engine: 8.2
Rated Cap: 60 bodies
was the old hose hard to take off?
like had to use a wrench all the way or just to break it lose and then took it off with youre fingers.
can you spin the nut on the new hose by finger before trying to connect it?
can you get both hands on the hose and connection?
i cant tell in the picture if the starter thread is damaged or not?
disconnect the other end of the hose to make it easier to hold straight with the male connector. put a little bit of fluid on the threads and try again.
unless youre new connector is so stiff you can not turn it with your fingers then you should be able to start it and tighten it at least halfway with your fingers.
do you still have your old hoses?
cut the good end off one at the hose and try to start it with out fighting the hose and see if it starts and or maybe use it as a thread chaser.
might be a minor little ding at the starter thread on the elbow?
if you can see it check there and maybe try to clean it up with a file,pocket knife,hack saw blade.
nothing crazy just make sure the end of the starter thread is clean,clear and not peeled out or pushed in.
look at the old connector and see what those threads look like? the previous installer could have had a problem also.
wish you luck
Jolly Roger bus 223 is offline   Reply With Quote
Old 09-16-2020, 06:42 PM   #10
Skoolie
 
Join Date: Oct 2018
Location: Central Alabama
Posts: 125
Year: 1998
Coachwork: Blue Bird
Chassis: TC/2000
Engine: 5.9 Cummins 12-valve
Rated Cap: 1
Quote:
Originally Posted by Beeb View Post
Update...

I got two new hoses made (I damaged the good one while trying to remove the bad one, so I had to replace the other one too). I got three of the four connections connected. But the last connection (where the leak originally was) is just spinning and spinning without catching and screwing on. I've tried everything I can, but I can't get it to take hold. I think the threads might be stripped on the transmission-side (not the hose - the hose looks fine). I'm not sure how to move forward...
At around 2:40 the threads look buggered up from cross-threading. The fitting on the trans seems to attach to the threads just above the nut. Use your wrench on the flat portion to turn the bad fitting and get it loose as it did when you removed the hose. Maybe the shop where the hoses were made can repair the thread or a local trans shop has a replacement.
Are the both female ends of the hose the same size?
BamaBus is online now   Reply With Quote
Old 09-16-2020, 06:52 PM   #11
Bus Geek
 
Join Date: May 2009
Location: Columbus Ohio
Posts: 13,480
Year: 1991
Coachwork: Carpenter
Chassis: International 3800
Engine: DTA360 / MT643
Rated Cap: 7 Row Handicap
the transmission fitting can be removed.. its a #8 ORB (O ring Boss)fitting to a flare fitting.. you can unscrew that jam nut a half turn or so just above the red.. and then the whole fitting unscrews out.. the way these work is that nut has a washer with amn O-ring below it.. when you thread the whole fitting in, you put it in most of the way and then get your orientation right and then tighten the jam nut down and this seals the fitting.. it allows you to make whichever direction you need. grainger sells many of these adapters as does various places online.. ive swapped a couple AT545s out to other transmissions I may even have some of these laying around in. my garage.. I often save such things..



an example


https://www.hydraulichoses.com/Produ...RoC6cgQAvD_BwE
cadillackid is offline   Reply With Quote
Old 09-16-2020, 06:53 PM   #12
Mini-Skoolie
 
Join Date: Jun 2018
Location: NW Florida
Posts: 68
Year: 2001
Coachwork: International
Engine: DT-466
Quote:
Originally Posted by Jolly Roger bus 223 View Post
was the old hose hard to take off?
like had to use a wrench all the way or just to break it lose and then took it off with youre fingers.
If anything, I thought it came off really easy. I wonder now if the original leak was just a bad connection - but I don't know why it would have started leaking now. I've been driving this bus for over 2 years, and haven't noticed any leaks since taking it to the shop last year once and earlier this year once.

Quote:
Originally Posted by Jolly Roger bus 223 View Post
can you spin the nut on the new hose by finger before trying to connect it?
Yes. Very easily.

Quote:
Originally Posted by Jolly Roger bus 223 View Post
can you get both hands on the hose and connection?
Sort of... if I really try, I can get both hands on it, but it's not super comfortable and I don't have much leverage.

Quote:
Originally Posted by Jolly Roger bus 223 View Post
i cant tell in the picture if the starter thread is damaged or not?
I can't tell either. I can't get close enough in person to see, so I only have the videos if I stick the camera in near the threads.

Quote:
Originally Posted by Jolly Roger bus 223 View Post
disconnect the other end of the hose to make it easier to hold straight with the male connector. put a little bit of fluid on the threads and try again.
I can hold it straight without disconnecting it. I have a lot of slack still. And I have fluid on the threads already.


Quote:
Originally Posted by Jolly Roger bus 223 View Post
unless youre new connector is so stiff you can not turn it with your fingers then you should be able to start it and tighten it at least halfway with your fingers.
I can turn it with my finger perfectly. But I spin it and spin it and spin it and spin it and it never takes hold. As soon as I let go of the hose, it just falls off.

Quote:
Originally Posted by Jolly Roger bus 223 View Post
do you still have your old hoses?
Unfortunately, no. When I got the new hoses made, I left the old ones at the shop.

Quote:
Originally Posted by Jolly Roger bus 223 View Post
might be a minor little ding at the starter thread on the elbow?
if you can see it check there and maybe try to clean it up with a file,pocket knife,hack saw blade.
nothing crazy just make sure the end of the starter thread is clean,clear and not peeled out or pushed in.
Ok. I'll see what I can come up with. It'll be hard to see what I'm doing on the back side, but I'll try

Quote:
Originally Posted by Jolly Roger bus 223 View Post
look at the old connector and see what those threads look like? the previous installer could have had a problem also.
wish you luck
Yeah, now that I'm seeing this, I'm really wondering if this is what the original problem was all along...

Quote:
Originally Posted by BamaBus View Post
At around 2:40 the threads look buggered up from cross-threading. The fitting on the trans seems to attach to the threads just above the nut. Use your wrench on the flat portion to turn the bad fitting and get it loose as it did when you removed the hose. Maybe the shop where the hoses were made can repair the thread or a local trans shop has a replacement.
Are the both female ends of the hose the same size?
Ok - I'll give that a try too.
Yes - all female ends of all the hoses are the same size.
Beeb is online now   Reply With Quote
Old 09-16-2020, 06:55 PM   #13
Mini-Skoolie
 
Join Date: Jun 2018
Location: NW Florida
Posts: 68
Year: 2001
Coachwork: International
Engine: DT-466
Quote:
Originally Posted by cadillackid View Post
the transmission fitting can be removed.. its a #8 ORB (O ring Boss)fitting to a flare fitting.. you can unscrew that jam nut a half turn or so just above the red.. and then the whole fitting unscrews out.. the way these work is that nut has a washer with amn O-ring below it.. when you thread the whole fitting in, you put it in most of the way and then get your orientation right and then tighten the jam nut down and this seals the fitting.. it allows you to make whichever direction you need. grainger sells many of these adapters as does various places online.. ive swapped a couple AT545s out to other transmissions I may even have some of these laying around in. my garage.. I often save such things..



an example


https://www.hydraulichoses.com/Produ...RoC6cgQAvD_BwE
Thanks. Is there a way to determine what size I need to get? Or are they typically all the same size?
Beeb is online now   Reply With Quote
Old 09-16-2020, 06:57 PM   #14
Bus Geek
 
Join Date: May 2009
Location: Columbus Ohio
Posts: 13,480
Year: 1991
Coachwork: Carpenter
Chassis: International 3800
Engine: DTA360 / MT643
Rated Cap: 7 Row Handicap
ther AT545 should have #8 ORB male and the flare should be #8 also.


#8 is the size.
cadillackid is offline   Reply With Quote
Old 09-16-2020, 06:58 PM   #15
Bus Geek
 
Join Date: May 2009
Location: Columbus Ohio
Posts: 13,480
Year: 1991
Coachwork: Carpenter
Chassis: International 3800
Engine: DTA360 / MT643
Rated Cap: 7 Row Handicap
in the part I losted it would be 6801LL-08-08
cadillackid is offline   Reply With Quote
Old 09-16-2020, 07:20 PM   #16
Mini-Skoolie
 
Join Date: Jun 2018
Location: NW Florida
Posts: 68
Year: 2001
Coachwork: International
Engine: DT-466
Ok. I see that says 1/2" JIC.

I know the other hose had a 5/8" connection, because I had to replace a part where it connected to the radiator. That hose ran from the filter to the radiator, and at the radiator side, it connected to a piece that was 5/8" flared connection on one side and 3/4" MIP on the other side. The 3/4" MIP side was screwed into the radiator. I replaced that part with an identical part I found at Home Depot, and the 5/8" fit perfectly. I was under the impression that these hoses all had the same size fittings. I can double-check. But if that's the case, wouldn't the 1/2" JIC be too small?

Here is the part I got at Home Depot. The 5/8" size fit perfectly.
Beeb is online now   Reply With Quote
Old 09-16-2020, 07:36 PM   #17
Bus Crazy
 
Jolly Roger bus 223's Avatar
 
Join Date: Sep 2017
Location: Swansboro,NC
Posts: 1,268
Year: 86
Coachwork: Thomas
Chassis: Ford B700
Engine: 8.2
Rated Cap: 60 bodies
most home improvement stores do not sell the fitting for what you need?
who made your hoses?
did you take youre used hoses with you?
you will not find the correct flare fitting in a home improvement store.
the correct fittings are what CADDILAC listed.
JIC 8 is a thing and is a different compression fitting than what you will find at a home improvement store.
they dont charge you for throwing them away but always keep your old lines at least until your issue is fixed.
Jolly Roger bus 223 is offline   Reply With Quote
Old 09-16-2020, 07:44 PM   #18
Skoolie
 
Join Date: Oct 2018
Location: Central Alabama
Posts: 125
Year: 1998
Coachwork: Blue Bird
Chassis: TC/2000
Engine: 5.9 Cummins 12-valve
Rated Cap: 1
Quote:
Originally Posted by Beeb View Post
Ok. I see that says 1/2" JIC.

I know the other hose had a 5/8" connection, because I had to replace a part where it connected to the radiator. That hose ran from the filter to the radiator, and at the radiator side, it connected to a piece that was 5/8" flared connection on one side and 3/4" MIP on the other side. The 3/4" MIP side was screwed into the radiator. I replaced that part with an identical part I found at Home Depot, and the 5/8" fit perfectly. I was under the impression that these hoses all had the same size fittings. I can double-check. But if that's the case, wouldn't the 1/2" JIC be too small?

Here is the part I got at Home Depot. The 5/8" size fit perfectly.
Would it be possible to return to HD or Lowes and make what you need? Would need to keep the bottom nut to position the fitting in the proper direction. I bought an elbow flare fitting last week for a gas line to install an oven.
BamaBus is online now   Reply With Quote
Old 09-16-2020, 07:45 PM   #19
Mini-Skoolie
 
Join Date: Jun 2018
Location: NW Florida
Posts: 68
Year: 2001
Coachwork: International
Engine: DT-466
Quote:
Originally Posted by Jolly Roger bus 223 View Post
most home improvement stores do not sell the fitting for what you need?
who made your hoses?
did you take youre used hoses with you?
you will not find the correct flare fitting in a home improvement store.
the correct fittings are what CADDILAC listed.
JIC 8 is a thing and is a different compression fitting than what you will find at a home improvement store.
they dont charge you for throwing them away but always keep your old lines at least until your issue is fixed.
The home improvement store didn't have this part. It had another part that connected to the radiator. The part that was originally on the bus was identical to the one I linked above. I have no idea why they had it, or why it was on the bus in the first place. I just know it was, and I know the flared end was 5/8".

I got the hoses made at a local diesel truck mechanic. I brought the old hoses with me to make sure he made an exact match. He measured the old hoses and said they were #10.

Yeah... I see now that I should have kept them. Lesson learned.
Beeb is online now   Reply With Quote
Old 09-16-2020, 07:47 PM   #20
Bus Crazy
 
Jolly Roger bus 223's Avatar
 
Join Date: Sep 2017
Location: Swansboro,NC
Posts: 1,268
Year: 86
Coachwork: Thomas
Chassis: Ford B700
Engine: 8.2
Rated Cap: 60 bodies
gotta be careful?
pay attention to inner diameter marked as ID and an outer diameter marked OD if it is even marked.
for example 5/8" od copper pipe for refrigeration tubing sealed is 1/2 ID copper pipe for plumbing. same stuff just labeled different.
the flare fitting you need is special.
JIC 8 means a JIC8
why couldnt you remove your old fitting from the line and re use it?
Jolly Roger bus 223 is offline   Reply With Quote
Reply

Tags
allison 545, help please!, leak, new mexico

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×