Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
 
Old 04-03-2022, 06:30 PM   #1
Mini-Skoolie
 
Join Date: May 2021
Location: South Carolina
Posts: 42
Year: 2005
Chassis: Thomas (37 ft)
Engine: 5.9 Cummins
Transmission light on

Hello all!my bus hasn't had any issues (besides killing the batteries once) the entire almost year I've owned it. I ran it fine a week or 2 ago. However I went to turn it on to burp the coolant today and the check transmission light came on. Does anyone have any advice? I'm supposed to move in on the 8th

Daybreakbus is offline   Reply With Quote
Old 04-04-2022, 08:45 AM   #2
Bus Crazy
 
ewo1's Avatar
 
Join Date: May 2015
Location: Central Tx.
Posts: 1,994
Year: 1999
Chassis: Amtran / International
Engine: DT466E HT 250HP - Md3060
Quote:
Originally Posted by Daybreakbus View Post
Hello all!my bus hasn't had any issues (besides killing the batteries once) the entire almost year I've owned it. I ran it fine a week or 2 ago. However I went to turn it on to burp the coolant today and the check transmission light came on. Does anyone have any advice? I'm supposed to move in on the 8th
Check the TCU fuse.
ewo1 is offline   Reply With Quote
Reply

Tags
transmission

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2024, vBulletin Solutions, Inc.