Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
 
Old 07-24-2021, 09:46 AM   #1
Mini-Skoolie
 
Join Date: Mar 2016
Location: Somewhere in the US
Posts: 63
Year: 2004
Coachwork: Blue Bird
Chassis: TC2000
Engine: Cummins 5.9
Rated Cap: 42
Voltage gauge troubleshooting

Hi everyone

I have a 2004 Blue Bird TC2000 and I need to track down what's happening with the voltage gauge on the instrument panel.

When the engine is running the gauge will usually show either 0v or be pegged out at over 16v.

I put a multimeter on the batteries while it was running and it read 14.3v which is what I would expect.

So I'm unsure how that gauge works and what part(s) need(s) to be replaced. Does it get a direct reading from the alternator/batteries or is there a sending unit somewhere that feeds that gauge in the instrument panel?

Thanks for your help - Gary

ghodges is offline   Reply With Quote
Reply

Tags
alternator, blue bird, instrument panel, tc2000

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.