Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
 
Old 09-23-2021, 08:09 AM   #1
New Member
 
Join Date: Sep 2021
Posts: 2
2018 Thomas Chevy express no brake lights

We’ve been working on a 2018 Thomas van on a Chevy express 2500 gas chassis. We are having an issue with no brake lights the tail light function works we’ve checked the wiring from the brake lights to the power distribution box in the bulk head when you give it 12v the brake lights work. However when you try to power it from the brake light switch there are no lights. Our scan tool is picking up a signal from the brake pedal at the com port. Anyone have this same issue or any idea where Tomas ties the body brake harness to the chassis harness?

MH5201 is offline   Reply With Quote
Old 09-23-2021, 11:19 AM   #2
Bus Crazy
 
Join Date: Sep 2018
Posts: 2,392
Year: 2007
Coachwork: Thomas Built
Chassis: Minotour
Engine: Chevy Express 3500 6.6l
Have you checked the fuses under the hood and the ones under the seat? If you’ve applied 12v to the brake light wire then you know you’re good to there. Since the brake lights tie into the cutaway, you’ll have a fuse upstream. To my knowledge, with the exception of the ignition interlock, TB doesn’t undo the circuitry when they build the bus.

If you can’t find a fuse (my bet is in the one under the seat) you can contact Daimler for assistance. You’ll need the VIN. You might just try James Smolder. It’s been a couple years since I emailed. He is very responsive, so if you don’t get something in a day go to the Thomas Built site and look for a customer support number. His email is

james.smolder_ii@daimler.com

I think your problem is in the cutaway area so look there first
Danjo is offline   Reply With Quote
Old 09-23-2021, 11:23 AM   #3
New Member
 
Join Date: Sep 2021
Posts: 2
After contacting Rohrer bus sales and service they pointed us in the right direction it ended up being the actual Thomas distribution box in the bulk head we had brake signal going in on the trailering wire side but none coming out to the LB16 brake light wire. Apparently there is a know issue with the solder joints breaking in the box
MH5201 is offline   Reply With Quote
Reply

Tags
thomas 2018

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:23 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.