Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
 
Old 01-05-2022, 03:18 PM   #1
New Member
 
Join Date: Jan 2022
Posts: 2
2004 4300 No Crank

Truck came to me with a mess of problems mainly no crank. I rewired fuses in battery box. I traced the main battery feeds and found one wire that was almost corroded in two. Repaired those and replaced a majority of the relay terminals in power distribution box as they were corroded. Everything appears to be decent, but it will not crank with key. Starer relay is receiving 12 volts from ignition switch. ECM is not sending out ground to relay. Would that short I found smoked the ecm? If I bypass starter relay, it cranks and runs good. Cleaned grounds and positive terminals. Also something that is acting up is wipers act like they have a mind of their own. May come on randomly. i was positive I found issue when i found that wire. Truck has an allison and it is recognizing park/reverse/etc. I'm stumped.

bgblk1968 is offline   Reply With Quote
Old 01-10-2022, 05:53 AM   #2
Skoolie
 
Join Date: Aug 2020
Location: East TN
Posts: 162
Year: 1999
Chassis: International
Engine: T444E
Try replacing the CPS? Then again, I guess it wouldn’t run if it were the cps. Cheap to buy though and try plus it’s good to have a spare.
Diverdude0075 is offline   Reply With Quote
Old 01-10-2022, 08:13 AM   #3
Bus Nut
 
Join Date: May 2015
Location: Miami, Fl.
Posts: 886
Year: 1999
Chassis: Amtran / International
Engine: DT466E HT 250HP - Md3060
Try pulling codes. If the ECM responds it might just not be toasted.

When you turn the key switch to the ON position, do the dash gauges “sweep”?

That is your Ecm post test indicator; that at least the ECM is trying to do it’s job.

Also you didn’ mention what engine your working with.
Did you check the ECM fuse?
ewo1 is offline   Reply With Quote
Old 01-17-2022, 08:39 AM   #4
New Member
 
Join Date: Jan 2022
Posts: 2
Dash does sweep and laptop see ecm. No codes. It runs fine when I jump starter solenoid. What tells the ecm to send ground signal to starter relay? I assume neutral safety switch, but is there anything else?


Oh, its a dt466E
bgblk1968 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2022, vBulletin Solutions, Inc.