Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
 
Old 09-19-2021, 07:50 PM   #1
New Member
 
Join Date: Aug 2021
Posts: 8
Engine running rough. T444e 1997 international

1997 international 4700 t444e replaced the high pressure injection pump. Now its running rough then smooths out then runs rough again. Engine code 164. Injection control pressure. Add normal rate of change. I also changed the icp. And IPR. When I changed the injection pump. If you Rev up the Engine it smooths out. Un till you let off the gas pedal. How do I fix this. I also have a pic of my live data for the oil pressure. I'm not sure how to down load it on here.
Once I figure it out I can also send a video of what it's doing.

Tommyboy8072002 is offline   Reply With Quote
Old 09-21-2021, 10:31 AM   #2
Commercial Member
 
Power Hungry's Avatar
 
Join Date: Jul 2020
Posts: 83
Sounds like air trapped in the Oil Rails. Remove the ICP sensor and add oil in the hole until it's full. Reinsert the sensor and see if that corrects the problem.
__________________
Bill Cohron
(AKA - That guy who turns arthritis and eye strain into electronic magic!)
Power Hungry is offline   Reply With Quote
Old 09-21-2021, 11:01 AM   #3
Bus Geek
 
Join Date: May 2009
Location: Columbus Ohio
Posts: 15,574
Year: 1991
Coachwork: Carpenter
Chassis: International 3800
Engine: DTA360 / MT643
Rated Cap: 7 Row Handicap
yeppers typical after an HPOP replacement.. it took a good while driving mine after I swapped my HPOP.



Bill has it right, you can fill the rail on the one head by removing the ICP and filling it up.. otherwise just drive it.. running some full throttle helps as that has the computer call for high HPOP pressure and lots more volume.



hopefully you replaced your IPR while you were at it and not with amazon Dorman crap. get a good quality IPR and ICP from dieselsite and you wont have issues with those.



mine cleared up after a few hours of driving .. and then it ran so much better than it had before with my tired HPOP.
cadillackid is online now   Reply With Quote
Old 09-25-2021, 08:00 AM   #4
New Member
 
Join Date: Aug 2021
Posts: 8
I bought the icp, Ipr and the Hpop from International dealer at the same time. I didn't want to take any chances. I pulled out the icp sensor dumped some oil in the hole. Drove it like I Stole it. Within a few minutes fixed the problem. Now runs good. Thank you everyone for your advice. Helped me out a lot
Tommyboy8072002 is offline   Reply With Quote
Old 09-26-2021, 10:09 PM   #5
Commercial Member
 
Power Hungry's Avatar
 
Join Date: Jul 2020
Posts: 83
Glad you're good now. Funny how little things like an air bubble can mess you up.

Taka care
__________________
Bill Cohron
(AKA - That guy who turns arthritis and eye strain into electronic magic!)
Power Hungry is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:47 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.