Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
 
Old 05-11-2022, 05:00 AM   #1
Mini-Skoolie
 
Join Date: Mar 2020
Posts: 20
5.9 Turbocharger Problem Wast Gate?

I have a 1997 Bluebird TC2000 with a 5.9 Cummins. It sat over the winter and now I have problem with performance. It starts and runs fine but I cannot get power once reved up. Also on hills it looses power and if I press to pedal to the floor. It seems to me that the turbo charger has a problem or the waste gate is stuck.

Any chance of testing this?
The turbo charger model is a Holset HX32M as far as I can read.

Thanks for your help!

Flitzeflap is offline   Reply With Quote
Old 05-11-2022, 07:34 AM   #2
Bus Geek
 
Join Date: May 2014
Location: West Ohio
Posts: 3,783
The wastegates can get stuck. I usually see it caused by rust, usually where the arm goes into the exhaust housing. Working the arm back and forth with your favorite penetrating oil will get it functional again. Might need to tap it with a hammer to get it broke free enough to wiggle it.

Or you can swap in a different unit.
__________________
My build: The Silver Bullet https://www.skoolie.net/forums/f11/p...llet-9266.html
Booyah45828 is offline   Reply With Quote
Old 05-11-2022, 10:35 AM   #3
Bus Crazy
 
turf's Avatar
 
Join Date: Apr 2013
Location: Colorado
Posts: 2,411
Year: 1993
Coachwork: bluebird
Engine: 5.9 Cummins, Allison AT1545
Rated Cap: 2
i dont have a boost gauge so its real hard to tell if the waste gate works or no. i was having problems with it myself for a while. so, adding a boost gauge is probably the easiest way to check it.

that said, i am comforted by the visual of my charge air pipes billow action when i romp on the accelerator pedal.

you can see it makes pressure as those pipes blow up. you should at least be able to feel those silicon covers expand a bit with the throttle. proof its working.
__________________
.
Turfmobile Build Thread
turf is offline   Reply With Quote
Old 05-13-2022, 02:46 AM   #4
Mini-Skoolie
 
Join Date: Mar 2020
Posts: 20
Thanks for the replies so far! The wast gate was completly rusted and wasnt moving at all. I ordered a new one. Hope this was the problem.
Flitzeflap is offline   Reply With Quote
Old 05-13-2022, 09:13 AM   #5
Bus Geek
 
Join Date: May 2014
Location: West Ohio
Posts: 3,783
You ordered a new actuator or waste gate? Typically the actuators don't rust frozen, they rust off. The waste gate will rust open, but it's replaced as the whole turbine housing, so I guess I'm confused as to what you have going on here.
__________________
My build: The Silver Bullet https://www.skoolie.net/forums/f11/p...llet-9266.html
Booyah45828 is offline   Reply With Quote
Old 05-13-2022, 02:08 PM   #6
Mini-Skoolie
 
Join Date: Mar 2020
Posts: 20
I ordered a new waste gate. I removed the old one and there was rust rattling in the can. The push rod could not be moved. So I hope that was my problem.
Flitzeflap is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2024, vBulletin Solutions, Inc.