Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
 
Old 03-05-2020, 02:59 PM   #1
Mini-Skoolie
 
Join Date: Sep 2019
Location: Loon Lake, NY
Posts: 68
Year: 2002
Engine: Cummins 8.3 ISC 300
Rated Cap: 36,200lbs
High Idle Control Help

My bus has switches for high idle control, and even has a big sticker above the driver seat that says to "Set throttle control at 1,200 RPMS when idling". But the buttons don't do anything. I've tried every combination of button presses and throttle positions and then button presses etc. But nothing seems to work. I checked the switch connections on the back of the panel and they seem fine. I've Googled for a few days with no luck, I'm hoping someone here can point me in the right direction of where to look next.
Attached Images
File Type: jpg 20200226_214159.jpg (316.7 KB, 10 views)
File Type: jpg 20200301_153410.jpg (122.7 KB, 9 views)

Neorush is offline   Reply With Quote
Old 03-05-2020, 04:01 PM   #2
Bus Nut
 
Join Date: Apr 2019
Location: Savannah GA
Posts: 756
Year: 2003
Coachwork: Bluebird
Chassis: TC2000
Engine: Cummins 5.9 24v
Rated Cap: 54 passenger
Quote:
Originally Posted by Neorush View Post
My bus has switches for high idle control, and even has a big sticker above the driver seat that says to "Set throttle control at 1,200 RPMS when idling". But the buttons don't do anything. I've tried every combination of button presses and throttle positions and then button presses etc. But nothing seems to work. I checked the switch connections on the back of the panel and they seem fine. I've Googled for a few days with no luck, I'm hoping someone here can point me in the right direction of where to look next.
Mine don't do anything either. The mechanic said they were disconnected. After I saw the wires still attached I emailed him and he said they get disconnected through the software. I assume from the ECM but it's on my list of things to look into later so I don't have the solution yet.
JDSquared is offline   Reply With Quote
Old 03-05-2020, 07:01 PM   #3
Mini-Skoolie
 
Join Date: Sep 2019
Location: Loon Lake, NY
Posts: 68
Year: 2002
Engine: Cummins 8.3 ISC 300
Rated Cap: 36,200lbs
Quote:
Originally Posted by JDSquared View Post
Mine don't do anything either. The mechanic said they were disconnected. After I saw the wires still attached I emailed him and he said they get disconnected through the software. I assume from the ECM but it's on my list of things to look into later so I don't have the solution yet.
This is actually really helpful to know. I'll do a little digging and see what I can figure out down that route.
Neorush is offline   Reply With Quote
Old 03-05-2020, 07:44 PM   #4
Bus Nut
 
Join Date: Apr 2019
Location: Savannah GA
Posts: 756
Year: 2003
Coachwork: Bluebird
Chassis: TC2000
Engine: Cummins 5.9 24v
Rated Cap: 54 passenger
Quote:
Originally Posted by Neorush View Post
This is actually really helpful to know. I'll do a little digging and see what I can figure out down that route.
LOL there's not much I can be helpful with on here, so it's a good thing "I don't actually know the answer yet" is at least somewhat helpful.

I commented because eventually one of us will have the answer and I can put it here for others.
JDSquared is offline   Reply With Quote
Old 03-05-2020, 08:03 PM   #5
Bus Crazy
 
Join Date: May 2016
Location: Georgia
Posts: 2,264
Year: 2001
Coachwork: Blue Bird
Chassis: IH
Engine: T444E
Rated Cap: 14
Usually these controls only function with parking brakes applied (this should be obvious, but just in case ...) Many places, to discourage extended idling, will computer-disable them in addition to setting a shutdown timer, usually between 5-10 minutes. The idle and cruise control can usually be changed in the computer settings.
Brad_SwiftFur is offline   Reply With Quote
Old 03-10-2020, 11:57 AM   #6
Mini-Skoolie
 
Join Date: Sep 2019
Location: Loon Lake, NY
Posts: 68
Year: 2002
Engine: Cummins 8.3 ISC 300
Rated Cap: 36,200lbs
Possible Solution

Had some back and forth with @specialskoolie who has pretty much the same engine. He had access to Cummins Insite and hooked the bus up. Here's his response:

Quote:
If you head to insight and go to features and parameters, there is a
"PTO/REMOTE PTO" option, you can enable and disable the communication to the ECM. That should read "ENABLE" if the switch is working correctly. We changed this and were able to cancel out the HIGH IDLE switch.

If you go over to the "DATA MONITOR/LOGGER" you can see the "REMOTE PTO SWITCH" option, if it is on or off. Regardless of whether it is enabled over on the parameters, you will see this switch on and off because it’s receiving voltage but this doesn’t show if it is communicating to the ECM.
It totally makes sense that they might disable a "PTO" flag before sending the bus on it's way. Now to find a local shop with Cummins Insite access.
Neorush is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.