Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
 
Old 06-23-2021, 09:04 AM   #1
Mini-Skoolie
 
Join Date: Oct 2020
Posts: 22
Inverter Showing ďAC AbnormalĒ

Hi, everyoneó

I have a Sungold 2000 Watt inverter, and I canít get AC power to work. It shows ďAbnormalĒ on the display. Itís the same problem as in this thread. Any ideas? My breaker box is wired the same as the OP on that thread.

I donít have it connected to shore power.

Thanks
Attached Images
File Type: jpg B121BD2B-6B7E-45A6-A3CF-245481E39944.jpg (197.0 KB, 8 views)
File Type: jpg F3364EE4-3AC5-454B-B912-C6F6C9AE650B.jpg (194.9 KB, 7 views)
File Type: jpg 99F70F62-1F8E-432E-AC42-B908EE5A9A7F.jpg (188.0 KB, 7 views)

sampatch is offline   Reply With Quote
Old 06-23-2021, 09:10 AM   #2
Mini-Skoolie
 
Join Date: Oct 2020
Posts: 22
Forgot to add the link. https://www.skoolie.net/forums/f49/i...mal-30159.html
sampatch is offline   Reply With Quote
Old 06-23-2021, 11:10 AM   #3
Bus Nut
 
Rwnielsen's Avatar
 
Join Date: Jun 2020
Location: Long Beach, CA
Posts: 455
Year: 1998
Coachwork: Blue Bird
Chassis: TC1000, 40' MPV
Engine: 5.9 Cummins/B300 trans
Rated Cap: U/K
Do you have a meter? Measure your input voltage both with inverter off and with it on, just to make sure that it's in the operating range. I would then disconnect all load wiring and check output voltage. If it needs a load to operate, find something like a lamp (100w incandescent) to plug in then check output voltage. Be careful, you're dealing with a lot of available power, both AC & DC.
Rwnielsen is online now   Reply With Quote
Old 06-23-2021, 11:20 AM   #4
Bus Nut
 
Rivetboy's Avatar
 
Join Date: Jul 2017
Location: Huntington Beach CA.
Posts: 905
Year: 1991
Coachwork: Bluebird
Chassis: T/C 2000 28 foot Handy Bus
Engine: Cummins 5.9 Mechanical
Rated Cap: 2
Quote:
Originally Posted by sampatch View Post
Hi, everyoneó

I have a Sungold 2000 Watt inverter, and I canít get AC power to work. It shows ďAbnormalĒ on the display. Itís the same problem as in this thread. Any ideas? My breaker box is wired the same as the OP on that thread.

I donít have it connected to shore power.

Thanks
I agree with Mr Nielson. Put your meter on it! Otherwise, went on line and read the manual and, not suprisingly, it does not address that error message. It has a 1 year warranty so can you return it? Finally, has it ever functioned ? A bad one out of the box seems all to common lately.

Joe
Rivetboy is offline   Reply With Quote
Old 06-23-2021, 11:23 AM   #5
Bus Nut
 
Rivetboy's Avatar
 
Join Date: Jul 2017
Location: Huntington Beach CA.
Posts: 905
Year: 1991
Coachwork: Bluebird
Chassis: T/C 2000 28 foot Handy Bus
Engine: Cummins 5.9 Mechanical
Rated Cap: 2
[QUOTE=Rwnielsen Be careful, you're dealing with a lot of available power, both AC & DC.[/QUOTE]


Remove all jewelery !
Rivetboy is offline   Reply With Quote
Old 06-23-2021, 02:04 PM   #6
Mini-Skoolie
 
Join Date: Oct 2020
Posts: 22
Thanks, folks. Iíll check all that out this evening. I can return/get the warranty coverage, so if I have to I can do that.
sampatch is offline   Reply With Quote
Old 06-23-2021, 09:14 PM   #7
Mini-Skoolie
 
Join Date: Oct 2020
Posts: 22
Hey, friends, we got it working. I checked all the connections and the plugged a hair dryer in while powering it up. It was too much, but it seemed to do something because now the lights turn on.

A new problem: the charger wonít charge. I donít have a 30a outlet at my house, so Iím using an adapter. Could that be why?
sampatch is offline   Reply With Quote
Old 06-23-2021, 09:20 PM   #8
Bus Nut
 
Rwnielsen's Avatar
 
Join Date: Jun 2020
Location: Long Beach, CA
Posts: 455
Year: 1998
Coachwork: Blue Bird
Chassis: TC1000, 40' MPV
Engine: 5.9 Cummins/B300 trans
Rated Cap: U/K
You'll get it, one thing at a time
Rwnielsen is online now   Reply With Quote
Old 06-23-2021, 09:27 PM   #9
Mini-Skoolie
 
Join Date: Oct 2020
Posts: 22
Thanks. Any ideas on why the charger wonít cut on? There are a lot fewer variables here. Wired the inlet, plugged it inÖ.and nothing.
sampatch is offline   Reply With Quote
Old 06-24-2021, 05:36 PM   #10
Mini-Skoolie
 
Join Date: Aug 2020
Location: Greensboro, NC
Posts: 37
Year: 2008
Coachwork: IC
Chassis: IC CE300
Engine: Maxxforce DT
As I wrote back last year : had the exact same issue with same inverter charger. I confirm that it needs to receive shore power before turning the inverter function on and deliver AC output.
Seb
Seb1 is offline   Reply With Quote
Old 06-24-2021, 05:39 PM   #11
Mini-Skoolie
 
Join Date: Oct 2020
Posts: 22
I must have missed that thread. I have it working now, but itís bouncing between float and fast charging every minute or so. Any thoughts?
sampatch is offline   Reply With Quote
Old 06-24-2021, 05:45 PM   #12
Bus Crazy
 
kazetsukai's Avatar
 
Join Date: May 2017
Location: Flemingsburg, KY
Posts: 1,429
Year: 1999
Coachwork: Amtran
Chassis: International RE
Engine: International T444e
Rated Cap: 76
Quote:
Originally Posted by sampatch View Post
I must have missed that thread. I have it working now, but itís bouncing between float and fast charging every minute or so. Any thoughts?
What's the battery voltage when this is happening?
kazetsukai is offline   Reply With Quote
Old 06-24-2021, 05:49 PM   #13
Mini-Skoolie
 
Join Date: Oct 2020
Posts: 22
Itís around 14, iirc. Iím not with it right now, but I can check later.
sampatch is offline   Reply With Quote
Old 06-25-2021, 11:32 AM   #14
Bus Crazy
 
kazetsukai's Avatar
 
Join Date: May 2017
Location: Flemingsburg, KY
Posts: 1,429
Year: 1999
Coachwork: Amtran
Chassis: International RE
Engine: International T444e
Rated Cap: 76
Quote:
Originally Posted by sampatch View Post
Itís around 14, iirc. Iím not with it right now, but I can check later.
Sounds like your batteries could be full.


Any loads on the system at all? DC or AC.
kazetsukai is offline   Reply With Quote
Old 06-25-2021, 11:58 AM   #15
Mini-Skoolie
 
Join Date: Oct 2020
Posts: 22
Yeah, I wondered that. I assumed theyíd ship to me at less than full. Thereís a little load, but only a very little.

I thought it would stay in float if they were full, though, but itís trying to do both, like I said. I wonder if I should disconnect from shore power, use the batteries a while with tools and whatnot this weekend, and see what happens after I know for sure that theyíre drained.
sampatch is offline   Reply With Quote
Old 06-25-2021, 12:09 PM   #16
Bus Nut
 
Rwnielsen's Avatar
 
Join Date: Jun 2020
Location: Long Beach, CA
Posts: 455
Year: 1998
Coachwork: Blue Bird
Chassis: TC1000, 40' MPV
Engine: 5.9 Cummins/B300 trans
Rated Cap: U/K
It sounds to me like you're hovering at the threshold between change and maintain. The small load only make it appear worse
Rwnielsen is online now   Reply With Quote
Old 06-25-2021, 12:13 PM   #17
Mini-Skoolie
 
Join Date: Oct 2020
Posts: 22
Quote:
Originally Posted by Rwnielsen View Post
It sounds to me like you're hovering at the threshold between change and maintain. The small load only make it appear worse

All right, great. Iíll use it on some heavy stuff this weekend and see what it does.

Now would be a good time to calibrate my monitor, I assume.
sampatch is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.