Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
 
Old 04-23-2021, 08:41 PM   #1
New Member
 
Join Date: Feb 2021
Posts: 4
Turn signal problem- help!

Hey all!
I have gone through all the wires, removed a ton and I'm down to what I think is finally the last wire. Everything works! Except... when I turn on the turn signal to turn right, right side (rear) lights blink as they should, when I turn on the signal to the left... right-side lights blink, but not the left. Running lights, brake lights, backup lights all work. My light monitor is reconnected. It seems a simple switch of cables or maybe moving one cable should fix this but I can't figure it out. Please help! I'm so close.

There is a 4-way connection just before the light monitor with two brown and two white cables that all connect via a small metal piece that I have never seen before. I feel like the problem is here, but again I can't find the solution. Thanks so much for any help you can offer!

TheRoHos is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:27 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2024, vBulletin Solutions, Inc.