Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
 
Old 06-18-2024, 03:51 AM   #1
New Member
 
Join Date: Jun 2024
Location: Florida, United States
Posts: 2
Year: 2008
Engine: CAT 3126
Electrical Issue in 99 Thomas Freightliner Bus

Hello,
My bus won't start. I've replaced the battery, the starter and the starter relay. The ignition switch bench tests just fine. I've secured all the safety doors and made sure the bus was in neutral in case it was a hidden switch somewhere getting in the way.

When I turn the key in the ignition, I can hear something clicking underneath the hood, but can't identify it what it is. It's slightly faster than 1 click per second, clicks 5-6 times, then stops. It sounds like that clicking is coming from a cluster of solenoid relays above the engine. I can't tell whether they are in between the starter relay and the starter - it looks like they might be, but that would also be confusing to me. I have not been able to find a wiring diagram for this beast. I don't want to replace all of them, but I will if I have to.

juniorfalcone is offline   Reply With Quote
Old 06-18-2024, 06:37 AM   #2
Bus Nut
 
Join Date: Oct 2018
Location: Central Alabama
Posts: 592
Year: 1998
Coachwork: Blue Bird
Chassis: TC/2000
Engine: 5.9 Cummins 12-valve
Rated Cap: 1
When you say "solenoid relay" are you referring to a cube or a round item? If you have proper voltage to the item(s) then you may have a bad ground. Somewhere.

Be specific on the bus you have and put it in your registry. It will help now and later.
BamaBus is offline   Reply With Quote
Old 06-18-2024, 09:59 PM   #3
New Member
 
Join Date: Jun 2024
Location: Florida, United States
Posts: 2
Year: 2008
Engine: CAT 3126
Quote:
When you say "solenoid relay" are you referring to a cube or a round item? If you have proper voltage to the item(s) then you may have a bad ground. Somewhere.
merge fruit
Be specific on the bus you have and put it in your registry. It will help now and later.
I got it. My problem was solved after I tried bypassing the a relay (looks like a starter solenoid) with a small jumper wire the same gauge as the other wires on the terminal.
juniorfalcone is offline   Reply With Quote
Old 06-19-2024, 11:24 AM   #4
Bus Crazy
 
ewo1's Avatar
 
Join Date: May 2015
Location: Central Tx.
Posts: 2,179
Year: 1999
Chassis: Amtran / International
Engine: DT466E HT 250HP - Md3060
Quote:
Originally Posted by juniorfalcone View Post
Hello,
My bus won't start. I've replaced the battery, the starter and the starter relay. The ignition switch bench tests just fine. I've secured all the safety doors and made sure the bus was in neutral in case it was a hidden switch somewhere getting in the way.

When I turn the key in the ignition, I can hear something clicking underneath the hood, but can't identify it what it is. It's slightly faster than 1 click per second, clicks 5-6 times, then stops. It sounds like that clicking is coming from a cluster of solenoid relays above the engine. I can't tell whether they are in between the starter relay and the starter - it looks like they might be, but that would also be confusing to me. I have not been able to find a wiring diagram for this beast. I don't want to replace all of them, but I will if I have to.
So much information but zero mention if the motor spins when you turn the key !
How do you know that it is a wiring problem.
ewo1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2024, vBulletin Solutions, Inc.