School Bus Conversion Resources

School Bus Conversion Resources (https://www.skoolie.net/forums/)
-   Electrical, Charging and Solar (https://www.skoolie.net/forums/f49/)
-   -   Renogy 40a DC to DC Charger, no green light (https://www.skoolie.net/forums/f49/renogy-40a-dc-to-dc-charger-no-green-light-37462.html)

BMWNJ 09-20-2021 07:40 PM

Renogy 40a DC to DC Charger, no green light
 
Well im stuck. It appears I have all of my wires ran correctly, the correct fuses in place and I'm getting power from the alternator side to the renogy charger (14.1v) but the unit itself is not powering on (no green light). I have the D+ line tapped into my ignition fuse. I also made up a test line and replaced the D+ line with a wire that went to a 12v battery to see if I could get a green light that way and it did not work.

Is my unit bad or am I missing something?

Rucker 09-20-2021 11:47 PM

I have one but I've not installed it yet. There are some troubleshooting youtube videos out there.

I would have done exactly what you've already done.

Danjo 09-21-2021 12:05 AM

I have a Renogy inverter-charger. It
Wasn’t working initially, but they know what dip switch settings to use

BMWNJ 09-21-2021 04:45 AM

Quote:

Originally Posted by Danjo (Post 453621)
I have a Renogy inverter-charger. It
Wasn’t working initially, but they know what dip switch settings to use

I forgot to mention the battery type im charging. I have lead acid deep cycle. All my dips are in the "on" position (down). I have 4 awg wire going from the bus side to the charger and 8 awg going from the charger into the house batteries. My wire runs are about 12-15 feet from the bus side and 3' from the charger into the house batteries. My D+ wire is 16 awg.

I saw they have a 1.4 version manual on their website (my unit came w 1.3) which is a little better than the one I have.

I've been going through youtube vids and other forum post but I'm not seeing much regarding no green light.

Drew Bru 09-21-2021 07:57 AM

woops, comment deleted.

BMWNJ 09-21-2021 09:08 AM

UPDATE: I figured out the problem. You need a ground on both ends of the unit. I came across that information on the blog posted below and it fixed my issue. I now have a green light on the unit and it is charging the battery. I will be adding a switch to the D+ line so I can kill power to it while the vehicle is operating and I dont need to charge the house batteries.


https://senormisterioso.wordpress.co...ravel-trailer/

Rucker 09-21-2021 11:46 AM

Quote:

Originally Posted by BMWNJ (Post 453659)
UPDATE: I figured out the problem. You need a ground on both ends of the unit. I came across that information on the blog posted below and it fixed my issue. I now have a green light on the unit and it is charging the battery. I will be adding a switch to the D+ line so I can kill power to it while the vehicle is operating and I dont need to charge the house batteries.


https://senormisterioso.wordpress.co...ravel-trailer/

Fantastic link and very detailed instructions-thank you for digging into this and sharing results!


All times are GMT -5. The time now is 01:42 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2022, vBulletin Solutions, Inc.